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New Features in V12 > 

Text Tool 
Description: Allows the automatic creation of text-based sketches for use in features 
Usage: Enter into a 2D sketch, press the text tool button, and enter the text, and format it. After applying the text, 
create a feature as normal. 
 

 

Color by Feature 
Description: Allows you to color parts of a model based on features 
Usage: Create a feature. In the Design Explorer, right click on the feature and select Feature Color. Select Specify 
Feature Color and define the color you would like. 

 



Set the Default Part Color 
Description: Allows you to select a default part color for all new parts 
Usage: Open a new part. Go to Edit > Color Properties. Choose a color, then click Make Default. 
 

 
 

Copy / Paste Stamper 
Description: Allows you to paste multiple copies of a copied item exactly where you want them. Works across 
workspaces. 
Usage: Copy something. Go to Edit > Paste Stamper. Begin clicking the mouse - the preview will show you where 
the item will be pasted before you click the mouse to apply.  
 

 



Customizable Toolbars 
Description: Create custom toolbars 
Usage: Right click on a toolbar. Select Customize Toolbars. Select New, name it, and then add the items you want.  
 

 
 

New Box Selection Methods 
Description: Dragging a box select from left to right selects only fully enclosed figures. Dragging from right to left 
selects fully and partially enclosed figures. 
Usage: See Description above 

 
 
 

 



Degree of Freedom Callouts - Sketching 
Description: When sketching, visual callouts can be turned on to notify you where you haven't defined the 
magnitude of figures (but not where you have not defined their position). Helps you to visually determine what 
remaining dimensions are required.  
Usage: Enter sketch mode and begin sketching. Turn on the DOF Callouts tool on the Sketching Options toolbar 
(new). You will see callouts on figures that do not have explicit magnitude dimensions. Click the callout to place a 
dimension without going into the dimension tool.  
 

 
 
 

Degree of Freedom Color Coding - Sketching 
Description: When sketching, figures can be color coded on the fly to visually represent whether they are fully 
defined, partially defined, or completely undefined. Use this to help you determine where a sketched profile requires 
more definition. 
 
Usage: Enter sketch mode and begin sketching. Turn on the DOF Colors tool on the Sketching Options toolbar 
(new). You will see your figures are now color coded per the legend at the bottom right of the screen.  
 

 
 



Real-time Dimensioning  
Description: When on, you can input dimensions for sketch figures while you are sketching to save time instead of 
sketching figures first and then dimensioning them later. 
 
Usage: Enter sketch mode. Turn on real-time dimensioning from the Sketching Options toolbar (new). While you 
sketch, you will see two boxes follow your cursor. To enter the boxes, press Tab. Switch between the boxes with Tab 
also. Tabbing out of a box also updates the preview to reflect the new change. Complete the figure by single clicking 
the mouse. A dimension is automatically applied. 
 
 

 
 

Quick Conversion Between Figures and Reference Figures 
Description: Previously only one figure could be converted at a time between being a reference figure and a regular 
figure. Now, you can convert multiple figures simultaneously. 
 
Usage: Select the figures you want to convert. They will turn blue as shown below. On the Sketch Options toolbar, 
select the appropriate button for converting the figures to Regular or Reference figures. The example below shows 
converting regular figures to reference figures. 
 

 



2D Constraint and Snapping Options 
Description: You can now set preferences for which constraints Alibre Design automatically places and polar 
snapping options. 
 
Usage: In a part workspace, select Sketch > Snap and Constraint Settings. Select or unselect which constraints you 
would like to be placed as you sketch. Set options for polar snapping as well.  
 
Note: Regardless of the options you define for constraint snapping, Alibre Design will always infer them. If a 
checkbox is off, Alibre Design simply will not place the constraint. You will get a visual indication that the constraint is 
being inferred, but the preview of the constraint will be light gray instead of the normal color. You can override the 
non-placement of a constraint by holding Shift before you finish the figure. 
 

 

Dimension Box (OK, Cancel) 
Description: You can now confirm or cancel dimensions without using the keyboard. 
Usage: When a dimension box is open, press the check mark or the cancel button. 
 

 
 

Mirror Over Axis (sketching) 
Description: You can now mirror figures directly over an axis without creating a reference line first 
Usage: Sketch some figures. Open the Sketch Mirror tool, select an Axis for the Mirror Axis, and press OK. 



Ability to Edit 3D Section Views 
Description: You can now change the properties of a section view instead of being forced to create a new one 
Usage: Right click on an existing section view in the Design Explorer. Select Edit. 

 

 

 

Animated View Transitions 
Description: When turned on, any time the view changes (going into sketch mode, reorienting on extrusions, and 
selecting view orientation buttons) the view transition will be gently animated instead of immediately snapping. 
Usage: This function works in the background. No specific usage is required. 

 

Default Color Scheme 
Description: A new default color scheme has been created.  
Usage: If you would like to use the default color scheme, and have previously defined a custom color scheme, 
simply select it from the list in the Color Schemes dialog. If you have never installed Alibre Design before, this 
scheme will be the default. 

 

Multiple Lights in 3D Workspaces 
Description: The model will never be black (overly shaded) any more. Up to 3 lights can be used, available in Tools 
> Options. The single light option has been tweaked to also prevent black areas. The model looks much nicer as 
well. 
Usage: Set the light number to 1, 2, or 3 in Tools > Options. 
 

 



Combined Move/Rotate Tools (Assembly) 
Description: The previous Move and Rotate tools have been combined into a single tool 
Usage: Select the Toggle Triad tool on the Assembly Modeling toolbar. Click on a part and the Triad pops up. Select 
portions of the triad based on what you want to do. You can perform several operations in a row. 

 

 

Reworked Assembly Pattern Dialogs 
Description: The linear and circular assembly pattern dialogs have been changed to be more consistent with 
pattern dialogs elsewhere in the product. 
Usage: N/A 
 

Contour Flange (Sheet Metal) 
Description: You can now automatically create a tab and multiple flanges using a single profile sketch 
Usage: In a sheet metal workspace, create a profile sketch. The sketch must contain at least one line (since there 
must be at least one tab), and can only contain lines and tangent arcs. After the sketch is created, select the Contour 
Flange tool and input the variables. You can also override individual bend radii after the Contour Flange has been 
created. Note that tangent arcs must have a tangent constraint applied. This would not be automatic, for example, if 
you projected a sketch from a solid that had a tangent arc. 
 

 
 



Lofted Flange (Sheet Metal) 
Description: You can now create lofted flanges between: circles/ellipses and squares/rectangles using a wizard  
Usage: In a sheet metal workspace, click the Lofted Flange tool. Determine which transition type you want, fill in the 
values, and press OK. 

 

 

Freeform Table Creation (2D Drawings) 
Description: You can now add tables to 2D drawings in a quick and efficient manner 
Usage: In a 2D drawing, select the General Table tool. Input the initial options for row and column count. Then, 
click on the table and click a field to edit it. You can format the text in the cells, drag the rows/columns around, 
merge cells, etc. 
 

 

 

Shaded and Visible Edges Mode Now Default 
Description: Previously the Shaded and Visible Edges display mode was not the default due to some performance 
issues on complex assemblies. This issue has been corrected and there is now almost no difference between Shaded 
and Shaded and Visible Edges performance.  
Usage: N/A 

 



 

Icon Previews for Parts/Assemblies/Drawings in Windows/Vault 
Description: Windows Explorer and the Alibre Vault will show icon previews for files saved in v12. 
Usage: Ensure that your Windows folder settings are set to display thumbnail previews.  
 

 

Substantial View Performance Increase for Large Assemblies 
Description: View interaction (rotate/pan/etc) has been substantially improved for large assemblies. Now, only the 
visible portion of the model is rendered – if you are zoomed in to a subsection of a large assembly, the subsection 
will have the same response as if you were viewing a single part.  
Usage: N/A 
 
 

Substantial 2D Drawing Import Performance Improvement 
Description: After importing DWG/DXF files, when you tried to edit the sheet on a large or very data intensive 
import some people experienced extreme performance degradation or crashes. This issue has been fixed. The most 
notable visual difference will be that nodes (endpoints) of figures are no longer all visible at once – they become 
visible when the mouse is hovered over a figure, but only for that figure. 
Usage: N/A 

 
 
 

Trim operation performance improvement for complex B-splines  
Description: Trimming operations used on complex B-splines during sketch mode could at times be slow. The 
performance has been much improved. 
Usage: N/A 
 
 
 



 

 

Assembly patterns have a preview 
Description: Linear and circular assembly patterns now have a preview in the workspace 
Usage: N/A 
 

 
 

 
 
 

New Home Window look 
Description: The Home Window now has a new graphical appearance 
Usage: N/A 
 

 
 
 
 
 
 
 
 
 
 
 
 
 



Equal angle option for circular patterns 
Description: Often you will want to create circular patterns in a complete circle. This option makes it so you are not 
required to manually calculate the angle based on the number of items in the pattern. 
Usage: When making a circular pattern of any type, select the Circular option under the Angle area of the dialog. 
 

 
 

Horizontal and vertical constraints now show on reference points 
Description: Horizontal and vertical constraints now appear on reference points that have them applied. 
Usage: Create horizontal and vertical constraints between nodes in the same way as usual. You will now be able to 
see the constraints and delete them. 
 

 



The default workspace size for a new sketch is now identical for all units 
Description: The default viewing area is now consistent between units. Those using mm will no longer have a very 
small starting workspace. 
Usage: N/A 
 

 
 
 

Open a 3D model directly from a 2D drawing 
Description: You can now open 3D models from a 2D drawing 
Usage: Right click on an item in the Drawing Explorer or on the edge of a projected item in the 2D workspace. 
Select Edit 3D Model. 

 

 



Picking the 2D section view direction before creating the view 
Description: You now pick the direction of the section view before creating it 
Usage: Select the figure you want to use to section the view. You will notice the arrows will change depending on 
what side of the figure your mouse is on. When satisfied, single click again to confirm the direction and the section 
view is created. 
 

 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 



Upgrading to v12 > 
Alibre Design Expert and Alibre Design Professional customers will need to update add-on applications according to 
the following guidelines. 

 

Add-on 
Application 

Add-on update 
required when 
moving to…  

v11 SP1     v12 

Update Instructions 

Alibre Vault N/A No 

Click here to view installation 
guidelines when installing for the 
first time. 
 
Note: The migration tool and 
instructions are located in the Program 
folder of your Alibre Design installation 
directory. 

Note: Do not uninstall the Alibre Vault 
when upgrading it. Choose the Simple 
Upgrade option from the installer. 

ALGOR DesignCheck No No 
Two versions are available;  

32-bit OS / 64-bit OS. 

Alibre Design for 
Rhino 3.0/4.0 

No No 

Uninstall via Add/Remove Programs; 
install new version. The Rhino 4.0 
add-on can be found on the 
Downloads page. 

Alibre Motion No No 
Uninstall via Add/Remove Programs; 
install new version. 

Alibre Part Library No No None 

Alibre PhotoRender No No 
Uninstall via Add/Remove Programs; 
install new version. 

Engineers Toolbox No No None 

Machinist Toolbox No No None 

    

http://www.alibre.com/products/vaultinstall.pdf


Add-on 
Application 

Add-on update 
required when 
moving to… 

v11 SP1     v12 

Update Instructions 

Alibre CAM No No 
Uninstall via Add/Remove Programs; 
install new version. 

Trace Parts No No None 

SolidWorks Reader No N/A None 

Sheet Layout No No None 

Free Dimension No No None 

PDF Creator No No None 

Red Eye RPM 
Instant Quote 

No No 
None 

Invent Better 

Suite 2008 
No No 

None 

Excel Add-on No No None 

 
Note: During install of any add-on, if presented the choice to Modify, Repair, or Remove the current installation, 
always select Remove. 

 

 

 

 

 

 



Minimum System Requirements > 

 

Supported Operating System 
 
   Windows XP Professional Edition or Home Edition 
   Windows Vista Basic, Business, Home, or Ultimate 
   Windows 7 Basic, Business, Home, or Ultimate 
 
32-bit and 64-bit systems supported 
 

Hardware Requirements 
 
Intel Pentium or equivalent processor: 2 GHz or faster 
RAM: 2 GB minimum  
Screen Resolution: 1024 x 768 minimum, 1280x1024 or greater recommended 
Video Card: 64 MB or higher, 128 MB minimum for Vista 
-  Card must support DirectX 9.0c 

Hard Disk Space: 500 MB 
DVD-ROM Drive (If installing from DVD) 
Mouse or pointing device 
 

Software Requirements 
 
Internet Explorer 6.0 or later  
.NET 2.0 Framework 
J# Redistributable  
DirectX 9.0c or later 
 
Note: If you do not have these, they will be installed automatically. 
 
 

 

 

 

 

 

 

 

 



Known Issues and Fixes > 
This section lists known issues. Workarounds are provided when available. 

Reinstallation of Alibre Design may be required after upgrading operating system 
When upgrading from Windows NT or Windows 98/ME to Windows XP, an un-installation and re-installation of Alibre 
Design may be required. No data will be lost in the process. This also applies to some of the add-ons, like Algor 
DesignCheck and VisualMill. 
 
To ensure Alibre Design is installed correctly after upgrading from Windows Vista to Windows 7, uninstalling Alibre 
Design and reinstalling is recommended. No data will be lost in this process. This also applies to some of the Add-
ons, like Algor DesignCheck and VisualMill. 

 

My screen is mostly just gray, and I can’t see any planes or model geometry 
If your workspaces are gray, ensure you have DirectX 9.0xc or greater. This will solve the problem the vast majority 
of the time.  
 
If you have DirectX 9.0c or greater and the problem persists, it is because your video card does not support a 
particular feature called Stencil Buffering. Nearly all video cards made in the last several years support this feature, 
but if yours does not there is a way to disable Alibre Design’s reliance on it. This disabling process will mean that you 
cannot use the new 2D Fast View mode when making a 2D drawing.  
 
To continue to use Alibre Design without this feature, in the Alibre Home Window go to Tools > Options > Display 
tab and select “Disabled” for the Advanced 2D Rendering combo box. After changing this setting Alibre Design will 
need to be restarted for the changes to take effect. 

 

Mouse-wheel zoom seems broken 
The Alibre Design graphics work area may not respond to mouse wheel input while other areas of Alibre Design will 
respond to mouse wheel input. This occurs frequently when a PS2 mouse is plugged in after the operating system 
has booted or the mouse driver is outdated. If using a Logitech mouse and the Logitech SetPoint software you will 
need to remap the mouse wheel in the software. 

 

Menus have graphical anomalies, disappear, or lag 
If experiencing issues with menu dropdowns such as the menu disappearing, or not refreshing correctly, this is most 
likely occurring because of the Microsoft Intellipoint mouse control software. Check your task manager for 
imouse.exe. If this is running you will need to uninstall this software or remove the startup process.  

 

 
 
 
 
 



Alibre Part Library is inaccessible 
The Alibre Part Library is a catalog of standard parts available to all Alibre Design Professional and Alibre Design 
Expert users. The Alibre Part Library requires an Internet connection to download requested parts. 
If you are experiencing intermittent problems accessing parts, please verify that you have an active and working 
Internet connection.  
 
If you do have a good Internet connection and still are unable to download parts, please check to see if you are 
connecting through a proxy-server. The Alibre Part Library will not download parts if your system is configured to use 
a proxy-server. To test, run the program ProxyServerTest.exe located on the Alibre Design product CD. 
If you are running through a proxy-server, please contact Technical Support for assistance. 
 
If you are unaware of what a proxy server is, then chances are this is not the case and you should  call Alibre 
Support.  

 

PhotoRender crashes when I close it 
 
Note: PhotoRender does not apply to you if you purchased Alibre Design v12 or later 

 
PhotoRender may crash when closing it if you are using an ATI graphics card and your graphics card driver is not up 
to date. Download and install the latest graphics card driver for your card.  

 

Overlapping sheet metal tab features change thickness 
All sheet metal algorithms assume the sheet metal stock has constant thickness throughout. The software uses this 
thickness value for a variety of purposes including offsetting dimple sketches, creating chopping blades in unbend/re-
bends, calculating several flange parameters, etc. Creating two or more flanges that overlap in space results in a 
non-uniform sheet thickness. Once this happens, several formulae and assumptions made in sheet metal algorithms 

become invalid. This is a limitation in the current software. Still, multiple tab features are valid as long as the uniform 
thickness is maintained. 
 
This is typically not an issue because sheet metal parts with overlapping tabs cannot be manufactured out of normal 
sheet stock to begin with and are rarely designed intentionally. 

 

Unable to create section view of broken view 
Creating a section view of a broken view results in a section view of the unbroken view to the extents of the defining 
section line. This is a limitation of the current software. 

 

My startup screen goes blank during a license update or update check 
Alibre Design can check for license updates automatically when you start the program. This is useful for example if 
you buy an upgrade and want the new functionality to reflect in your currently installed version of Alibre Design 
immediately. Occasionally, there may be a blank or non-responsive screen for a few seconds. 
This is simply a failure to update the visual progress; however the license update process is continuing in the 
background. Please allow the update to continue without interruption. If you do not want to perform license checks 
upon starting Alibre Design, please turn this option off in Home Window > Tools > Options. 
 



A sheet metal dimple is failing when my profile has B-Splines 
Alibre Design can create sheet metal dimples with closed B-spline profiles provided the sketches are tangent 
continuous at the start-end location. 'B-spline by Interpolation Points' does this automatically when you make the 
start and end locations coincident. You must ensure this manually if you are using B-spline by Control Points by 
defining the 2nd last control point to lie on the start location tangent line at the provided location hint. You do this 
while sketching the spline’s last two control points; it cannot be done after finishing the spline. 

 

Limitations mirror and pattern features in part workspaces 
- Shelled features cannot be mirrored or patterned. 
- Local operations such as remove, move, or offset face cannot be mirrored or patterned. 
- Sheet metal flange features cannot be mirrored or patterned. 
- Imported geometry such as IGES and SAT bodies cannot be mirrored or patterned. 
- Mirrored or patterned features of parts that have been scaled will be created to the original scale. 
- Topology Pattern features cannot be patterned or mirrored. 

 

How do I get back an instance of an assembly pattern I deleted 
When an instance of an assembly pattern is deleted, and needs to be restored, the pattern will have to be recreated. 

 

I changed some appearance options for sketching and they aren’t reflected 
Some visual options such as constraint icon size, sketch color, or node size will not be reflected immediately if you 
are active in a sketch when you make the change. Simply exit your sketch and re-enter it and the changes are 
reflected from that point onwards. 

 

I get section view hatching problems when using Fast Views and un-sectioned parts 
If you are using Fast Views there may be some issues when creating section views that contain specifically un-
sectioned parts. If you have overridden a part’s section status so it does not appear as sectioned within the view, 
anything that is sectioned begin in the view will show through.  
 
This is a limitation of Fast View mode, and converting the view to a Precise View mode will solve the problem. 

 

Alibre CAM 1.x won’t generate toolpaths for sketches made by the text tool 
Alibre CAM 1.x cannot interpret a text symbol, which is created by default when using the text tool in 3D modeling. 
To create toolpaths based on sketches that contain text, you must explode the text symbol. To do this: 
 
   Edit the sketch that contains the text 
   Double click the text 
   The Text dialog pops up 
   Select the Explode button 
 
Alibre CAM 2.x and later will not have this issue. 
 
 



Known Issues in Windows Vista 

I get some graphical anomalies occasionally, such as a temporary gray screen 
This can occasionally be an issue when you are using the Windows Aero Theme in Vista and do not have a sufficient 
computer to run Windows Vista with the Aero Theme and Alibre Design simultaneously.  
 
The first thing to check is that you have the most current graphics driver for your video card. If that does not fix the 
issue, you should consider upgrading your hardware (RAM, Video Card). If you need help determining what area of 
your system is likely causing the problem, you can contact Customer Support. 
 
Note that this problem can be eliminated by turning off the Windows Aero Theme in Windows Vista, though you may 
prefer to upgrade your system so you can keep the slick visuals it brings. 

 

The Excel add-in isn’t working properly 
Microsoft Excel has to be run “As Administrator” in order for the Excel add-in (Spreadsheet driven design) to work 
correctly. Before working on Spreadsheet driven design, right click on the Excel icon and choose to “run as 
Administrator” and then open a file manually.  

 

I can’t run the MSI file to install Alibre Design 
When installing from the DVD, you will not be able to run MSI file for installing the product on Vista. Always use 
Setup.exe to install the product. This will always work and is the normal recommended way in general to install Alibre 
Design. 

 

ETBX is not able to use Vista Aero visual theme 
 

Sprutcam 4.0 (legacy) does not work in Vista 
SprutCAM 4.0 will have to be explicitly run as Administrator when running it from outside of Alibre Design.  
 

Algor Designcheck or VisualMill doesn’t work after upgrading from XP to Vista 
After upgrading from XP to Vista, if you had already installed Algor DesignCheck or VisualMill on XP you will have to 
uninstall and re-install these add-ons on Vista.  

My 3D Connexion device isn’t working on Vista 
In order to run the 3D Connexion driver, you may have to explicitly run the driver as an Administrator by right 
clicking on it and choosing to run as Administrator.  

 

VisuallMill will not install on Vista 64 
VisualMill will not install on 64 bit Windows Vista. Please contact Customer Support for updates. Alibre CAM does 
install on 64 bit machines.  
 

Machinist Toolbox Help doesn’t work on Vista 64 
Help may not work in Machinist Toolbox with 64-bit Vista. This is a limitation of Machinist Toolbox. 
 



APPENDIX – Useful Information 

Tips for Dimensioning to Holes with Cosmetic Threads 
When dimensioning to holes with cosmetic threads displayed, be sure to select the hole geometry instead of the 
cosmetic threads. 

 

Alibre Design and Windows XP Remote Desktop 
Standard Microsoft Windows XP Remote Desktop configurations do not support DirectX accelerated displays and 
Alibre Design will not display correctly in a Windows XP remote desktop window. Consider switching to a different 
remote access application such as VNC or GoToMeeting or installing Alibre Design locally. 

 

Versioning is not available when using the Windows File System 
The Alibre Vault provides file management capabilities not available in the Windows file system, such as versioning, 
sharing and security, and caching. If you do not have a version of Alibre Design that supports the Alibre Vault and 
you need file management capabilities, please contact your sales representative. 

 

How to Contact Alibre Customer Support  
Alibre is committed to ensuring that customer support issues and technical questions are handled as efficiently and 
promptly as possible. For all issues related to sign-in, launch and general technical problems, contact Alibre Customer 
Support: 
 
Phone 972-671-8492, press 4 for Support or ext. 300 
 
Email support@alibre.com 
 
Online Incident Entry  
The Alibre web site - http://www.alibre.com/ - offers additional support options. After you sign in at the web site, 
click the Support & Training link at the top. 
 
Now, expand the Support link on the left side to reveal options to enter a new Support Incident online or to check 
the status of existing incidents.  

 

 

mailto:support@alibre.com

